Results 1 to 5 of 5

Thread: How to install MediaWiki 1.7 (php5)

  1. #1
    Registered
    Join Date
    Aug 2006
    Location
    Brest/France
    Posts
    3
    Rep Power
    0

    Unhappy How to install MediaWiki 1.7 (php5)

    Hi,

    Do you know how it's possible to install MediaWiki 1.7 ?

    Please, help me to understand the results obtained installing it (see errors at the end) :

    -------------------------------------------
    ...hitcounter table already exists.
    ...querycache table already exists.
    ...objectcache table already exists.
    ...categorylinks table already exists.
    ...logging table already exists.
    ...user_newtalk table already exists.
    ...transcache table already exists.
    ...trackbacks table already exists.
    ...externallinks table already exists.
    ...job table already exists.
    ...langlinks table already exists.
    ...querycache_info table already exists.
    ...filearchive table already exists.
    ...ipblocks table does not exist, skipping new field patch
    ...ipblocks table does not exist, skipping new field patch
    ...recentchanges table does not exist, skipping new field patch
    ...recentchanges table does not exist, skipping new field patch
    ...recentchanges table does not exist, skipping new field patch
    ...recentchanges table does not exist, skipping new field patch
    ...have user_real_name field in user table.
    ...have user_token field in user table.
    ...have user_email_token field in user table.
    ...have user_registration field in user table.
    ...have log_params field in logging table.
    ...have ar_rev_id field in archive table.
    ...have ar_text_id field in archive table.
    ...have page_len field in page table.
    ...have rev_deleted field in revision table.
    ...image table does not exist, skipping new field patch
    ...image table does not exist, skipping new field patch
    ...image table does not exist, skipping new field patch
    ...site_stats table does not exist, skipping new field patch
    Adding iw_trans field to table interwiki...ok
    ...ipblocks table does not exist, skipping new field patch
    ...site_stats table does not exist, skipping new field patch
    ...already have interwiki table


    Warning: mysql_num_fields(): supplied argument is not a valid MySQL result resource in /xxxxx/htdocs/includes/Database.php on line 1133



    Notice: Trying to get property of non-object in /XXXXXXX/htdocs/maintenance/updaters.inc on line 156

    Updating indexes to 20031107: Query "ALTER TABLE `xxxxlinks`
    DROP INDEX l_from,
    ADD INDEX l_from (l_from)
    " failed with error code "Table 'xxxx.xxxxlinks' doesn't exist (mysql12.powweb.com)".
    -----------------------

    With these errors install is stopped.

    What can i do to resolve it ?

    Thanks for suggestion.

  2. #2

    Join Date
    Jun 2005
    Location
    US
    Posts
    32
    Rep Power
    12
    I can confirm that MediaWiki 1.6.7 works on Powweb. I haven't had a chance to try 1.7 yet, but hopefully I will update mine within the next couple of weeks. The only thing that I can think of off the top of my head is that maybe the mysql server addresses are different after the migration? Sorry, I know that wasn't much help.

  3. #3
    Registered
    Join Date
    Oct 2005
    Location
    Fullerton, CA
    Posts
    8
    Rep Power
    0
    I succesfully upgraded to 1.7.1. I had some hitches in the process that were entirely my fault. It works like a charm. www.suwiki.org. first tell us what process you used to upgrade? I recommend using the process they give - make backups first of everything! Then copy the new files into the wiki directory. Then browse to the wiki url and run through all the install stuff there. Make sure you give all the correct mysql table data information - login anme and password, table prefix. Once I figured that part out, it ran pretty smooth for me. I installed the upgrade AFTER being converted to the new OPS system if that matters.

    Chris Fullmer

  4. #4
    Registered
    Join Date
    Aug 2006
    Location
    Brest/France
    Posts
    3
    Rep Power
    0
    Thank you for answer.

    Now after many difficulties, it works, but when i consult phpMyAdmin, i watch serveral strange messages for three tables :

    revision La colonne `rev_page` ne devrait pas faire partie à la fois d'une clé primaire et d'une clé index
    Créer une clef sur colonne(s)

    categorylinks Plus d'un index de type INDEX existe pour la colonne `cl_to`

    hitcounter Aucune clef n'est définie !

    It doesn't seem to disturb the software...

    And the worst is that my site is very slow...

    But it seems i'm not alone for that...

    Pierre

  5. #5
    Registered
    Join Date
    Oct 2005
    Location
    Fullerton, CA
    Posts
    8
    Rep Power
    0
    Well, glad it works. I translated the errors and I am not sure what it all means. I don't really enough about the inner workings of the wiki to help. You could try goint to the wiki irc channel and aksing them. They might be able to tell you if the error is important or not.

    Chris Fullmer

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •