Results 1 to 5 of 5

Thread: Coppermine Uploads Fail Memory error

  1. #1
    Registered
    Join Date
    Nov 2007
    Location
    Michigan, USA
    Posts
    6
    Rep Power
    0

    Coppermine Uploads Fail Memory error

    I have recently come to Powweb after the the company that I previously used for web picture albums closed that part of their business. I have successfully set up a Coppermine gallery and have been happily uploading pictures with FTP. As of last weekend this has failed. I can upload either by FTP or by the Coppermine upload files function but I cannot load them into an album. Note: I was able to load and delete a 16kb .gif file this evening.


    ________________________
    Error using Coppermine - Upload file process (a 492kb .jpg file). Note that this occurs after the Upload complete. It is at the "Please click 'Continue' to add the files to albums." stage that the error occurs

    Fatal error: Allowed memory size of 16777216 bytes exhausted (tried to allocate 8192 bytes) in /hermes/web05/b1187/pow.MySite/htdocs/CopperMine/include/picmgmt.inc.php on line 262

    Error in the CGI error log from Coppermine Batch Upload. Note that the uploads via FTP worked just fine. This occurs at the final stage of loading into an album.

    Allowed memory size of 16777216 bytes exhausted (tried to allocate 224 bytes)

    __________________________

    I don't know if this is a Coppermine, PHP, MySQL, or POWweb issue, so I'm looking for any suggestions.

    Coppermine gallery size: 936 files in 26 albums and 13 categories

    Thanks

    Richard

  2. #2
    YvetteKuhns's Avatar
    Join Date
    Feb 2003
    Location
    Allentown, PA USA
    Posts
    15,244
    Rep Power
    34
    We discussed possible causes in other forum threads here. You may need to change your php.ini file. Or you may need to optimize your database. Are you running the latest version of Coppermine?
    Yvette Kuhns
    Power Pages Web Design
    Customized Internet Advertising Solutions

  3. #3
    Registered
    Join Date
    Nov 2007
    Location
    Michigan, USA
    Posts
    6
    Rep Power
    0
    Thanks for the quick reply.

    I was one step back at 1.4.8 (upgrade to 1.4.10 is available and now completed). Being new at this I am a bit concerned about blindly doing upgrades.

    I have searched (a little) on this topic, but am a little hesitant about diving in too blindly. However, I guess I should do the upgrade first.

    [Upgrade completed. Errors remain the same alas.]

    Are these the lines in PHP.INI to edit:

    max_execution_time = 30 ; Maximum execution time of each script, in seconds
    max_input_time = 60 ; Maximum amount of time each script may spend parsing request data
    memory_limit = 16M

    I do see your posting on optimizing the DB. That is probably my last option.

    It's getting late so I will try tomorrow.

    Thanks

    Richard

  4. #4
    Registered
    Join Date
    Nov 2007
    Location
    Michigan, USA
    Posts
    6
    Rep Power
    0
    Solved: Thanks for the pointer for editing the php.ini file.

    I increased memory_limit from 16 to 32 and the uploads worked. Note: after further review I have reduced that to 20 (memory_limit=20)

    From the coppermine forums, the gd library memory usage is pixel based, not file size based. I failed to shrink these as I had most of the others

    I will remember in the future to pre-shrink the files first.

    Richard

  5. #5
    YvetteKuhns's Avatar
    Join Date
    Feb 2003
    Location
    Allentown, PA USA
    Posts
    15,244
    Rep Power
    34

    Thumbs up

    Nice job! Glad it is working.
    Yvette Kuhns
    Power Pages Web Design
    Customized Internet Advertising Solutions

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •