Results 1 to 3 of 3

Thread: Drupal installation problem

  1. #1
    Registered
    Join Date
    May 2007
    Location
    Detroit
    Posts
    4
    Rep Power
    0

    Drupal installation problem

    When I access the site installed through Install Central of Drupal 6.4 the install routine appears to be successful. Database created, all the files in place.

    I opened up the website and it said it couldn't connect me to my database. It had the proper name for the database server too, which is on custsql-pow20 according to the MySql admin tool. I checked the CGI Error Log and saw PHP errors in one of the basic includes. Those are usually caused by insufficient PHP memory allocation.

    Being an experienced Drupal admin (been working with it two years), I know those errors are caused by insufficient PHP memory allocation. I found PHP4 memory was 8M. That's beneath the minimum to run Drupal which is 16M. I typically alter runtime variables to head up to 64M, because added modules need more memory.

    These are the relevant lines from the file /sites/default/setup.php, these go at the end of the PHP SETUP section:
    Code:
    ini_set('memory_limit', '64M');
    ini_set('register_globals', '0');
    Is Powweb going to be moving up to PHP 5 soon?
    Is there a chance the default 8M memory limit could be set to 16M or higher?

  2. #2
    Former Spam Filter (EU) IanS's Avatar
    Join Date
    Mar 2004
    Location
    Washington (THE original UK one!)
    Posts
    12,964
    Rep Power
    30
    PHP5 is available, and has been for a very long time, here at Powweb!

    You can set PHP to default to PHP5 within OPS or use the extension PHP5 on each file.

    The database server is addressed using username.powwebmysql.com. This is the official way to address the server.
    This is a Powweb customer
    helping Powweb customer forum.

    I am a customer just like you!!

    Some matters can only be answered by staff or support.
    Give it a go - ask here first!

  3. #3
    Mod.. with bite.. Croc Hunter's Avatar
    Join Date
    Sep 2002
    Location
    Australia
    Posts
    7,332
    Rep Power
    26
    An experienced Drupal Admin of two years should know to always install Drupal manually you knucklehead. Here at Powweb you can ensure PHP5 is in use and edit the php.ini limit settings in OPS> Main> CGI and Scripted Language Support> PHP Scripting> Select PHP5 from the drop down field> Apply> Then scroll down and edit your memory etc limits. You can be wreckless and put 6644 for the memory limit though as a shared hosting environment Powweb monitors such activity to prevent excessive draining of CPU and server resources.
    Croc Hunter MSC :

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •