Results 1 to 10 of 10

Thread: Any ideas why this site is slow?

  1. #1
    Mod.. with bite.. Croc Hunter's Avatar
    Join Date
    Sep 2002
    Location
    Australia
    Posts
    7,332
    Rep Power
    26

    Any ideas why this site is slow?

    Guys I updated www.streetsie.com to a Wordpress platform in hope of reducing CPU demand and page load times. Old html parsed as php in 6 or 7 seconds now take 10 or 15, even pages with no images. Can someone tell me why?

    It got slammed from Google PR 5 to 3 and subpages 3 to 0 even with 301 SEO friendly redirects and all. I'm thinking it's related. Why is the site so slow?
    Croc Hunter MSC :

  2. #2
    PowWeb Staff Dbrazzell's Avatar
    Join Date
    Nov 2008
    Location
    Burlington
    Posts
    489
    Rep Power
    20
    Are you still having a problem with this?

    I just looked at the site and Firebug is telling me the site is loading between 5 and 6 seconds.

    Also the page looks the same as it did before. Did you switch back to the old style of site after wordpress was not working out?

  3. #3
    Mod.. with bite.. Croc Hunter's Avatar
    Join Date
    Sep 2002
    Location
    Australia
    Posts
    7,332
    Rep Power
    26
    Thanks for checking, it's still the Wordpress version and still taking 15+ to load for me. I wondered if it's because I'm so far away in Australia. I also thought it may be a plugin dragging azz. Is there a way to check how many queries a page pulls?

    Here's another Powweb Wordpress site I've been developing in my spare time. It loads in 8-10 sec for me [removed] so I kinda ruled out a distance issue.
    Last edited by Croc Hunter; 12-9-09 at 11:24 PM.
    Croc Hunter MSC :

  4. #4
    PowWeb Staff Dbrazzell's Avatar
    Join Date
    Nov 2008
    Location
    Burlington
    Posts
    489
    Rep Power
    20
    That one loaded in 4 to 5 seconds for me.

    Your orginal site does make a pretty big number of requests. The firebug plugin for wordpress said 78 total.

    The second site was a lot lower at 22

    I dont know if the plugin was messed up or something but when I looked at the first site a lot of .jpg and other files were called twice.

  5. #5
    Mod.. with bite.. Croc Hunter's Avatar
    Join Date
    Sep 2002
    Location
    Australia
    Posts
    7,332
    Rep Power
    26
    Do you mean Firebug plugin for Firefox? I see what you mean about double even tripple image calls. Firebug tells me 75 images 1.09Mb taking 20 sec to load. If you click "Featured Content" on homepage you'll see why. Disabling the Featured Content plugin breaks the site.

    Thanks for the tips dbrazzell, I've narrowed it down. When I changed 7 featured image/articles to 2 and disabled the Wordpress NextGEN Gallery plugin it halved load time. Might just have to live with it until I can install Gallery3.
    Croc Hunter MSC :

  6. #6
    Beta tester
    Join Date
    Jul 2005
    Location
    California
    Posts
    627
    Rep Power
    13
    Croc, it loads in about 4 to 5 seconds for me in California.

  7. #7
    Mod.. with bite.. Croc Hunter's Avatar
    Join Date
    Sep 2002
    Location
    Australia
    Posts
    7,332
    Rep Power
    26
    Thanks KitBear that's interesting. I'm on an ADSL2+ connection and download at about 162Kbps (as I live 5km from the exchange). You guys must be pulling about 486Kbps.
    Croc Hunter MSC :

  8. #8
    Registered
    Join Date
    May 2009
    Location
    Karachi, Pakistan
    Posts
    6
    Rep Power
    0
    It loaded in about 4 seconds for me.

    Also, in the FC slider, it should read "Heroes..." and not "Hero's..."

  9. #9

    Join Date
    Jan 2005
    Location
    Seattle, WA
    Posts
    70
    Rep Power
    13
    Did you ever get this resolved. I'm researching site slowness here on Powweb as a fresh install with no plugins is terribly slow. My site is www.techlinks.com. Looking for guidance to optimize load time on Powweb. Any suggestions?

  10. #10
    Mod.. with bite.. Croc Hunter's Avatar
    Join Date
    Sep 2002
    Location
    Australia
    Posts
    7,332
    Rep Power
    26
    No, I stil find it sluggish. In fact like yours at this minute it is not accessable at all, showing a 403 forbidden error :/.
    Croc Hunter MSC :

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •