Results 1 to 3 of 3

Thread: Joomla (1.5.15) upgrade fix {{PHP 5 IS available!}}

  1. #1

    Join Date
    May 2009
    Location
    UK
    Posts
    40
    Rep Power
    0

    Joomla (1.5.15) upgrade fix {{PHP 5 IS available!}}

    I'm posting this here as a bit of help for anyone who has recently upgraded Joomla to the latest version and found a lot of script errors if they use the 'breadcrumb' display method, if you have seen "Warning: cannot yet handle MBCS in html entity decode" then you will know what I'm talking about. I apologise if its already been posted.

    I updated and anywhere I was using breadcrumb within articles I was getting a lot of errors. It turns out the latest version is built for php version 5, which Powweb is yet to upgrade (for my site at least, I'm still on version 4.xx).

    Anyway if you aren't on php 5 and are getting these errors I have found the culprit line of code that fixes the problem, it is situated at:

    • libraries/joomla/application/pathway.php


    Edit this file and overwrite the old one with the following changes;

    At line 209 replace;

    • $item->name = html_entity_decode($name, ENT_COMPAT, 'UTF-8');


    With;

    • $item->name = html_entity_decode($name);


    That should now display your content properly again. I really hope this helps someone because its been driving me nuts!

    Any of you guys/mods know when php is going to be upgraded? I'm finding increasing amounts of modules for my site I can't use because they require version 5, which we don't have....

  2. #2
    Former Spam Filter (EU) IanS's Avatar
    Join Date
    Mar 2004
    Location
    Washington (THE original UK one!)
    Posts
    12,964
    Rep Power
    30
    PHP4 is the default version but PHP5 is available as standard for everyone - you simply change it in OPS, under PHP scripting (you need to be logged into OPS to use this link) as outlined in the knowledgebase article.
    You can also use PHP5 files by using the PHP5 extension instead of PHP.

    This has been the case for a very long time.
    This is a Powweb customer
    helping Powweb customer forum.

    I am a customer just like you!!

    Some matters can only be answered by staff or support.
    Give it a go - ask here first!

  3. #3

    Join Date
    May 2009
    Location
    UK
    Posts
    40
    Rep Power
    0
    Oh man I did NOT know that, so presumably there should be many others that don't realise also, I've just checked 'Enhanced Script LIbrary' and you are indeed correct.

    Ah well, hopefully this will help other people out with the same issue, thanks for the reply Ian!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •