Results 1 to 2 of 2

Thread: Perl problem maybe - as of 9-15-10?

  1. #1
    Registered
    Join Date
    Oct 2004
    Location
    Boston, MA
    Posts
    13
    Rep Power
    0

    Perl problem maybe - as of 9-15-10?

    I run a small Perl script as a virtual include to increment a page counter scheme. Been using it for years. Just found out that it ceased operating about 11 AM server time on 15-Sept-10. Used Live Chat to report it but they didn't have a handle on it and are bumping it up.

    I use this script on every page of a weekly newsletter - about 50 per year, and 10 years worth in archives, so my whole scheme of about 500 pages are now not incrementing the counters. A page that displays the current static page count for me is working but all that is doing is reading the static text files via virtual include.

    Live Chat told me to check the programmer to get info on permissions but I had to repeat that this script is not a new add and has been working for well over 5 years for me and ceased, per server records, at 11 AM on 15-Sept. That is the last time one of the text files incremented.

    The error message is: Error. Count file "/home/users/web/b1017/pow.nci/htdocs/cgi-bin/c4g.count" not writable or non-existant.

    I have checked all of the permissions and they are OK. None have changed and I certainly haven't changed any myself.


    Dennis K.
    NCI

  2. #2
    Registered
    Join Date
    Oct 2004
    Location
    Boston, MA
    Posts
    13
    Rep Power
    0
    Quote Originally Posted by NCI View Post
    The error message is: Error. Count file "/home/users/web/b1017/pow.nci/htdocs/cgi-bin/c4g.count" not writable or non-existant.

    Post Script... I ran the CGI checker and the syntax is OK.

    This error as displayed is generated by my script when it cannot write to a file or if the file to be written-to is missing. So it appears the script is working. It appears that there may be a server level restriction on allowing writing by the script or to the text files. The individual permissions are set as they should.

    I'm wondering if this is causing the other script issues I am reading on this forum?

    DMK
    NCI

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •