Results 1 to 7 of 7

Thread: do you use drupal and have clean URLs set up?

  1. #1
    Registered
    Join Date
    Aug 2011
    Location
    Libertyville, IL
    Posts
    4
    Rep Power
    0

    drupal htaccess

    I need help understanding the htaccess process for making clean URL's for Drupal. I have a .htaccess file in my root web directory, and I also have a .htaccess.txt file in my drupal installed directory.

    I've looked at instructions on how to set up clean URL's, but I can't seem to

    1) figure out where to make the change (I am assuming the drupal htaccess file)
    2) what code to change?

    this is my .htaccess.txt file within my drupal directory.


    #
    # Apache/PHP/Drupal settings:
    #

    # Protect files and directories from prying eyes.
    <FilesMatch "\.(engine|inc|info|install|make|module|profile|te st|po|sh|.*sql|theme|tpl(\.php)?|xtmpl|svn-base)$|^(code-style\.pl|Entries.*|Repository|Root|Tag|Template|a ll-wcprops|entries|format)$">
    Order allow,deny
    </FilesMatch>

    # Don't show directory listings for URLs which map to a directory.
    Options -Indexes

    # Follow symbolic links in this directory.
    # For security reasons, Option followsymlinks cannot be overridden.
    #Options +FollowSymLinks
    Options +SymLinksIfOwnerMatch

    # Make Drupal handle any 404 errors.
    ErrorDocument 404 /index.php

    # Force simple error message for requests for non-existent favicon.ico.
    <Files favicon.ico>
    # There is no end quote below, for compatibility with Apache 1.3.
    ErrorDocument 404 "The requested file favicon.ico was not found.
    </Files>

    # Set the default handler.
    DirectoryIndex index.php

    # Override PHP settings. More in sites/default/settings.php
    # but the following cannot be changed at runtime.

    # PHP 4, Apache 1.
    <IfModule mod_php4.c>
    php_value magic_quotes_gpc 0
    php_value register_globals 0
    php_value session.auto_start 0
    php_value mbstring.http_input pass
    php_value mbstring.http_output pass
    php_value mbstring.encoding_translation 0
    </IfModule>

    # PHP 4, Apache 2.
    <IfModule sapi_apache2.c>
    php_value magic_quotes_gpc 0
    php_value register_globals 0
    php_value session.auto_start 0
    php_value mbstring.http_input pass
    php_value mbstring.http_output pass
    php_value mbstring.encoding_translation 0
    </IfModule>

    # PHP 5, Apache 1 and 2.
    <IfModule mod_php5.c>
    php_value magic_quotes_gpc 0
    php_value register_globals 0
    php_value session.auto_start 0
    php_value mbstring.http_input pass
    php_value mbstring.http_output pass
    php_value mbstring.encoding_translation 0
    </IfModule>

    # Requires mod_expires to be enabled.
    <IfModule mod_expires.c>
    # Enable expirations.
    ExpiresActive On

    # Cache all files for 2 weeks after access (A).
    ExpiresDefault A1209600

    <FilesMatch \.php$>
    # Do not allow PHP scripts to be cached unless they explicitly send cache
    # headers themselves. Otherwise all scripts would have to overwrite the
    # headers set by mod_expires if they want another caching behavior. This may
    # fail if an error occurs early in the bootstrap process, and it may cause
    # problems if a non-Drupal PHP file is installed in a subdirectory.
    ExpiresActive Off
    </FilesMatch>
    </IfModule>

    # Various rewrite rules.
    <IfModule mod_rewrite.c>
    RewriteEngine on

    # If your site can be accessed both with and without the 'www.' prefix, you
    # can use one of the following settings to redirect users to your preferred
    # URL, either WITH or WITHOUT the 'www.' prefix. Choose ONLY one option:
    #
    # To redirect all users to access the site WITH the 'www.' prefix,
    # (http://example.com/... will be redirected to http://www.example.com/...)
    # adapt and uncomment the following:
    # RewriteCond %{HTTP_HOST} ^cubbiesbasball\.com$ [NC]
    # RewriteRule ^(.*)$ http://www.cubbiesbaseball.com/$1 [L,R=301]
    #
    # To redirect all users to access the site WITHOUT the 'www.' prefix,
    # (http://www.example.com/... will be redirected to http://example.com/...)
    # uncomment and adapt the following:
    # RewriteCond %{HTTP_HOST} ^www\.example\.com$ [NC]
    # RewriteRule ^(.*)$ http://example.com/$1 [L,R=301]

    # Modify the RewriteBase if you are using Drupal in a subdirectory or in a
    # VirtualDocumentRoot and the rewrite rules are not working properly.
    # For example if your site is at http://example.com/drupal uncomment and
    # modify the following line:
    RewriteBase /cbb
    #
    # If your site is running in a VirtualDocumentRoot at http://example.com/,
    # uncomment the following line:
    # RewriteBase /

    # Rewrite URLs of the form 'x' to the form 'index.php?q=x'.
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteCond %{REQUEST_URI} !=/favicon.ico
    RewriteRule ^(.*)$ index.php?q=$1 [L,QSA]
    </IfModule>

    # $Id$

  2. #2
    Former Spam Filter (EU) IanS's Avatar
    Join Date
    Mar 2004
    Location
    Washington (THE original UK one!)
    Posts
    12,964
    Rep Power
    30
    Your file .htaccess.txt won't be being processed at all.

    I can't advise on changes to the txt file for drupal, however to get this file implemented you need to remove the .txt extension - including the period.
    This is a Powweb customer
    helping Powweb customer forum.

    I am a customer just like you!!

    Some matters can only be answered by staff or support.
    Give it a go - ask here first!

  3. #3
    Registered
    Join Date
    Aug 2011
    Location
    Libertyville, IL
    Posts
    4
    Rep Power
    0
    i figured it was the txt file in the drupal dir. However, if i change that to .htaccess, the drupal site will crash.

  4. #4
    Registered
    Join Date
    Aug 2011
    Location
    Libertyville, IL
    Posts
    4
    Rep Power
    0
    ok, i found that I need to stay in the htdocs .htaccess file. So, I am in there and made some changes, but I still can't seem to get the Drupal Clean URL's to be configured right. Anyone have any ideas?
    this is what I have:


    RewriteBase /cbb
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteCond %{REQUEST_URI} ^/cbb/(.*)$
    RewriteRule ^(.*)$ /cbb/index.php?q=$1 [L,QSA]

  5. #5
    Registered
    Join Date
    Aug 2011
    Location
    Libertyville, IL
    Posts
    4
    Rep Power
    0

    do you use drupal and have clean URLs set up?

    can someone help me with the code to configure this properly? I can't get clean URLs to work for the life of me.
    Last edited by IanS; 8-7-11 at 06:21 AM. Reason: MOD NOTE: Two threads on same topic merged into correct forum.

  6. #6
    slck0's Avatar
    Join Date
    Oct 2004
    Location
    Atlanta, GA
    Posts
    81
    Rep Power
    14
    brymcg, did you ever figure this out? I'm having the same problem today -- new install of Drupal 7 and can't get the clean urls to work.

  7. #7

    Join Date
    Feb 2009
    Location
    India
    Posts
    174
    Rep Power
    9
    Comment the line Options +SymLinksIfOwnerMatch (it will cause internal server error) and try whether its working.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •