Results 1 to 6 of 6

Thread: Using ASX to "stream" WMA

  1. #1
    Registered
    Join Date
    Dec 2012
    Location
    Home
    Posts
    5
    Rep Power
    0

    Using ASX to "stream" WMA

    When I was with another host I was able to "stream" my wma audio files by using a simple .asx file. Now that I am on powweb and using wordpress I simply transferred my files over (same domain name) but now when you click a link for my asx file to load my wma, I get an "Error 404 - Not Found". Any ideas?

  2. #2
    target='_blank' snowmaker's Avatar
    Join Date
    Nov 2002
    Location
    Not in Solomons anymore.
    Posts
    3,441
    Rep Power
    21
    Provide a link, and I'll take a look and try to figure this out. It's probably an issue of the file not being where the link is targeted to.
    -bruce /* somdcomputerguy */
    'If you change the way you look at things, the things you look at change.'

  3. #3
    Registered
    Join Date
    Dec 2012
    Location
    Home
    Posts
    5
    Rep Power
    0
    Thanks!

    Our site is http://www.mikeandholli.net/music

    Seems to me (in my total lack of really understanding what's wrong) that everything should work fine since this is the same setup I had with my old web host. Only difference now for me is that I am using wordpress.

  4. #4

    Join Date
    Feb 2009
    Location
    India
    Posts
    174
    Rep Power
    9
    added mime type for asx through .htaccess editor?As per wiki mime type is video/x-ms-asf .If it doesnt work goooogle!!!!

  5. #5
    Registered
    Join Date
    Dec 2012
    Location
    Home
    Posts
    5
    Rep Power
    0
    That's not working. I've even tried manually editing the .htaccess file. Here's what it looks like.

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress

    video/x-ms-asf asf asx
    audio/x-ms-wma wma
    audio/x-ms-wax wax
    video/x-ms-wmv wmv
    video/x-ms-wvx wvx
    video/x-ms-wm wm
    video/x-ms-wmx wmx
    application/x-ms-wmz wmz
    application/x-ms-wmd wmd

    Switching to Powweb has been one headache after another for a site that ran fine for 9 years.

  6. #6
    Registered
    Join Date
    Dec 2012
    Location
    Home
    Posts
    5
    Rep Power
    0

    Smile

    IT WORKS!

    According to Powweb support, the folder permissions have to be set to "755" and the file permissions should be "644".

    Also, I had to move my folder containing my audio files (thus making it a subfolder) into the "htdocs" folder. No rewriting asx's or .htaccess editing.

    My site is now fully functional.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •