Results 1 to 3 of 3

Thread: Current version of PERL on Powweb

  1. #1

    Join Date
    Dec 2004
    Location
    Ames, Iowa
    Posts
    33
    Rep Power
    13

    Current version of PERL on Powweb

    Hi,

    I was trying to use the new "state" declaration in a PERL script and discovered this is not implemented until PERL version 5.10 (released Dec 18, 2007)

    As of today May 22, 2014, Powweb currently runs PERL version 5.8.8 (released Jan 31, 2006) http://transition.powweb.com/faq.html#CGI

    The latest stable PERL release = version 5.18.2 (released Jan 6, 2014) http://www.perl.org/get.html

    Perl version history: http://perldoc.perl.org/perlhist.html

    I know there are not too many PERL users out there anymore, but would it be time to update to the latest PERL release since the version on Powweb is 8+ years old? I can live without the new functionality, but was thinking more along the lines of security holes in the old versions. Here is a listing of vulnerabilities: http://www.cvedetails.com/product/13...vendor_id=1885

    If Powweb did upgrade / migrate to 5.18.2 would it break all the existing PERL scripts and cause utter pandemonium?

  2. #2
    target='_blank' snowmaker's Avatar
    Join Date
    Nov 2002
    Location
    West Virginia
    Posts
    3,457
    Rep Power
    22
    Powweb staff do not frequent this forum (it's mainly for customer to customer help), so I would suggest you open a ticket or perhaps try the online support chat feature to try and get answers more quickly to one or both of these questions, or wait for a response here. That might be a day or so, or a month or few..

    However, the upgrade/script breaking changes question may be able to be answered by another customer who 'has the know' for this, due to experience here, or somewhere else.
    -bruce /* somdcomputerguy */
    'If you change the way you look at things, the things you look at change.'

  3. #3

    Join Date
    Dec 2004
    Location
    Ames, Iowa
    Posts
    33
    Rep Power
    13
    agreed, before I open a ticket I thought I would bounce it off some other Powweb PERL users to see what they thought. My thought, is in general it is good to keep up with the latest releases, mainly because of security issues.

    When I moved my site here many many years ago, I recall it took a few brain cycles to port my PERL code because of differences in the systems.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •