Results 1 to 6 of 6

Thread: jquery form stopped working

  1. #1

    Join Date
    Jun 2004
    Location
    australia
    Posts
    55
    Rep Power
    13

    jquery form stopped working

    Hello
    I have a couple of simple forms on my site that suddenly stopped working four days ago. They were working fine for several years with a security code and if somehting was missing or security code was wrong there was a proper message that told the user they had it wrong. and if everything was correct a proper message said thank you your message has been sent. Now if one just hits the send button a window comes up saying the page says success!
    and ofcourse it is all wrong and no email is sent
    I have no clue what went wrong.i did not change anything. Can anyone direct me to what is going on. this is a link to one of the forms that are not working:
    http://www.arabworldbooks.com/Readers/Application.htm

    someone helped me with these forms a few years ago. the script and all the files have not changed at all and have been working alright till some days ago.

  2. #2
    Rick
    Join Date
    May 2002
    Location
    Minneapolis, MN
    Posts
    1,752
    Rep Power
    18
    Line 29 seems to have been broken into two lines. This sometimes happens when a webmaster uses a word processing program to edit the HTML file. Be sure to use a plain text editor like Notepad, and combine lines 29 and 30 back together as one.
    Rick Trethewey

  3. #3

    Join Date
    Jun 2004
    Location
    australia
    Posts
    55
    Rep Power
    13
    Rick
    thank you for your time.
    you were spot on regarding line 29 and 30 but I don't think it is the spaces.
    What I noticed on that line is a link that I never put there. It is not in the code of the page but appears online on the server.

    the code should be :
    result = '<div class="notification_ok">Your message has been sent. Thank you! </div>';

    but on the server it looks like this
    result = '<div class="notification_ok">Your message has been sent. Thank you! <a href="http://fancyratstudios.com/installment-loans-for-bad-credit-arizona/">installment loans for bad credit arizona</a>
    </div>';

    I uploaded fresh files from my desktop to the server of all related script and html.
    the link to fancyratstudios keeps appearing in the source although i did not put it there and it is not in the code of the page.

    the form uses jquery script and i uploaded a fresh one. scans of the files as well as a wordpress install that I use for the theme of the page come back negative.

  4. #4
    Rick
    Join Date
    May 2002
    Location
    Minneapolis, MN
    Posts
    1,752
    Rep Power
    18
    Hmm... the code is different than I recall it from earlier today. I see the bad credit loans link now.

    It certainly looks like your site has been hacked. I'd suggest that you search on "remove malware from Wordpress" and learn how to check for malware and repair your site. You should also do a thorough virus scan of your own computer. Good luck!
    Rick Trethewey

  5. #5
    Custom User Title entrecon's Avatar
    Join Date
    Aug 2006
    Location
    Michigan
    Posts
    2,742
    Rep Power
    16
    Probably make sure Wordpress is Up-to-date too
    ________________________________
    Find me on twitter: @entrecon

  6. #6

    Join Date
    Jun 2004
    Location
    australia
    Posts
    55
    Rep Power
    13
    thanks for your time and responses.
    I actually managed to clean the code and get the forms running.
    however it seems that the wordpress install i have which is on a small section of my site is infected. I need to look into how to clean that up quickly.
    I alerted support to the problem particularly that online there seems to be news of 100,000 wordpress sites infected by unknown malware since december 15 and there may be full wordpress sites here who have been hit and aren't aware of it.
    anyhow thanks guys for your help.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •