Results 1 to 5 of 5

Thread: Primary Domain changed in OPS

  1. #1

    Join Date
    Mar 2007
    Location
    Louisiana
    Posts
    75
    Rep Power
    11

    Question Primary Domain changed in OPS

    My first domain is 9 years old. I bought a second one a few years after the first and pointed it to my first domain.

    I'm pretty sure I had the oldest as my primary domain but now the second one is showing as primary.

    The only explanation I can think of, is that something got changed when I had to call and straighten out a billing problem with the two domains and corresponding privacy which took quite a few calls and support tickets over a few years time.

    Or maybe it was more recent and I just never noticed.

    I have no idea if this has caused a problem with my website though I have wondered about some things recently in trying to figure out SEO problems.

    I changed the primary domain back to my older domain in "Select Your Primary Domain".

    Will I notice any problems after doing this?

    [EDIT] The reason I started checking into my domain status is because I came across a few of my images in Google search that showed mysite.powweb.com instead of mysite.com as the url for the image.
    Last edited by barbara; 4-1-15 at 07:33 PM. Reason: added info

  2. #2
    Former Spam Filter (EU) IanS's Avatar
    Join Date
    Mar 2004
    Location
    Washington (THE original UK one!)
    Posts
    12,964
    Rep Power
    30
    It's always been possible to access your site via the powweb.com sub-directory (at least for many, many years). The new thing must be the bots using that route.

    I also have multiple domains and multiple accounts and the listing for the link to the second account is via the lowest domain name, ie the first in the alphabet. I've just assumed it's alphabetical order. I've no idea if it makes any difference as these are fun accounts so I don't worry about search engines etc.
    This is a Powweb customer
    helping Powweb customer forum.

    I am a customer just like you!!

    Some matters can only be answered by staff or support.
    Give it a go - ask here first!

  3. #3

    Join Date
    Mar 2007
    Location
    Louisiana
    Posts
    75
    Rep Power
    11
    Thanks Ian. Bots could be an explanation. And yes, it could be alphabetical order too. We'll see what happens since I changed it. Powweb does say the default is the oldest domain though.

    Yes, it is a hobby account for me too but I still want it to be found and learn something in the process about how it all works.

    I just noticed that on Yahoo my site shows up fine in search under my second domain. I've noticed Yahoo finding the second domain over the last few years.

    Google seeems to change algorithms more than a snake sheds its skin. That's not to say Google = snake. Or does it?

  4. #4
    Rick
    Join Date
    May 2002
    Location
    Minneapolis, MN
    Posts
    1,753
    Rep Power
    19
    I don't think it's worthwhile trying to resolve any potential SEO issues the arise from the labyrinth of Powweb's mirrored servers and subdomain structure. Somewhere, somehow, Googlebot discovered a URL that pointed to your site where it resides within the subdomain of powweb.com, and it just kept following the links. The best and easiest solution is to set up 301 redirects on any domains where the HTTP_HOST ends with 'powweb.com' instead of the intended domain name using your .htaccess file. Something like:
    Code:
    RewriteEngine On
    RewriteCond %{HTTP_HOST}  ^*\.powweb\.com$
    RewriteRule ^(.*)$ http://www.yoursite.com/$1 [R=301,L]
    or, if you don't use subdomains:
    Code:
    RewriteEngine On
    RewriteCond %{HTTP_HOST}  !^www\.yoursite\.com$
    RewriteRule ^(.*)$ http://www.yoursite.com/$1 [R=301,L]
    Note that this is untested, off-the-cuff, but it should be close. Remove the 'www.' from the RewriteRule if you don't normally use it in your Preferred URL. This will also ward off any other canonicalization issues. Good luck!
    Rick Trethewey

  5. #5

    Join Date
    Mar 2007
    Location
    Louisiana
    Posts
    75
    Rep Power
    11
    Rick! Thanks so much for the redirect info. I'll try it and see what happens.

    I'm a little vague on the use of htaccess and redirects but I've gotten some good tips here on the forum in the past. So thank you.

    And with SEO, I really don't know what I'm doing but I just try to check my site, Powweb and Google Analytics and follow suggestions especially when my site stops showing up on the first page of search results.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •