Results 1 to 2 of 2

Thread: WordPress force HTTPS and change all HTTP links to HTTPS?

  1. #1
    Registered
    Join Date
    Nov 2012
    Location
    Miami
    Posts
    2
    Rep Power
    0

    WordPress force HTTPS and change all HTTP links to HTTPS?

    I just installed SSL on one of my sites. While it's working well on the main site, it's not on the wordpress blog here. I have added this snippet in .htaccess of the blog:

    Code:
    RewriteCond %{HTTPS} !=on
    RewriteRule ^ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]
    But it's still not fully secure with some assets not in secure mode. I used Httpfox to check all the HTTP requests and all HTTP requests are correctly redirected to HTTPS. Now I don't know why it's still not fully secure. I thought redirecting all HTTP assets to HTTPS would be the deal in this case? Is it?

    If not, it seems the only option left for me is to manually change all HTTP assets (href, src, etc.) to HTTPS across all the content. Is there any easy way to achieve this for the entire WP blog? A plugin? This doesn't seem right to me as I'm afraid it would neglect one asset or two on some of the posts or pages.

    This really sucks.....any help would be appreciated!

  2. #2
    Rick
    Join Date
    May 2002
    Location
    Minneapolis, MN
    Posts
    1,753
    Rep Power
    19
    You'll need to do some detective work to find the issue(s). Chances are that it will be related to a plug-in.

    First, let your home page load in your browser and then take a look at the source code with View -> Page Source or CTRL-U. Use the 'Find' feature to locate any instances of 'http://' and make note of them. You especially want to look for references to external websites/domains, since they won't be affected by your redirect. On a good day, you should be able to deduce the source of the bad reference from its URL. If you think you've found a match between an http:// reference and a plug-in, check the plug-in's Settings to see if you need to update it to use https://. Otherwise, deactivate and then re-activate that plug-in so that it will understand it's in an https:// environment. If that doesn't help, you may have to remove and completely re-install the latest version. And if that doesn't work, you'll want to remove it and look for an alternative.

    If you can't see an obvious connection between an external http:// reference and a plug-in, you'll have to go through them all. Deactivate all of your plug-ins, and then re-activate them one-by-one until the problem reappears.
    Rick Trethewey

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •