Results 1 to 3 of 3

Thread: HTML image elements mysteriously disappearing?

  1. #1
    Registered
    Join Date
    Nov 2012
    Location
    Miami
    Posts
    2
    Rep Power
    0

    HTML image elements mysteriously disappearing?

    Please see here, scroll down to Product Gallery and there should be several large dress images but they are not displaying at all.

    When I check the HTML code and they are all there and the images are all correctly showing up if I access them directly in the browser. However, when I use Firebug to examine the <img> elements they seem to be faded out or hidden or something.

    I tried to add these CSS styles via Firebug to the <img> elements on .product_images_exhibit img:

    Code:
    display: inline !important;
    visibility: visible !important;
    But nothing happens. However if you go to the HTTP version (not HTTPS), the images are all displaying properly.

    This is really weird to my understanding. What is wrong and what's actually preventing the <img> elements to be rendered?

    Maybe Javascript? But I have no idea how to find out which JavaScript line is preventing these elements to be showing. How can I find them?

    Any help would be very much appreciated!

  2. #2
    Custom User Title tpoynton's Avatar
    Join Date
    Sep 2004
    Location
    Mass
    Posts
    2,177
    Rep Power
    18
    for some reason the width and height are not set on https page - you can see this in the code if you compare side-by-side the secure and non-secure pages.

  3. #3
    Thinkin' out loud again Builder's Avatar
    Join Date
    Nov 2002
    Location
    Illinois
    Posts
    2,088
    Rep Power
    20
    Same image.
    http:
    Code:
    <img src="http://www.princessly.com/media/catalog/product/cache/1/image/e54b44b8d0417aeeb7e4f8b7c94ab956/i/m/img_7638/Princessly.com-K1000104-Ivory-Lace-Blush-Pink-Tulle-Flower-Girl-Dress-31.jpg" width="848" height="1272" alt="" title="" />
    https:
    Code:
    <img src="https://www.princessly.com/media/catalog/product/cache/1/image/e54b44b8d0417aeeb7e4f8b7c94ab956/i/m/img_7638/Princessly.com-K1000104-Ivory-Lace-Blush-Pink-Tulle-Flower-Girl-Dress-31.jpg" width="" height="0" alt="" title="" />
    Notice the difference in width and height. Especially height="0" which means that image won't display. Why it's happening I don't know. But perhaps this gives you a clue on where to start looking.

    EDIT: Oops, basically the same as tpoynton stated... Oh, well.

    Good luck,
    Kevin
    A good friend will come and bail you out of jail...
    but a true friend will be sitting next to you saying,
    "Damn... that was fun!"

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •